vue 安装sass-loader 报错 this.getResolve is not a function

javascript/jquery

浏览数:91

2020-6-16

进行sass-loader,node-loader的安装后报错,

this.getResolve is not a function 一直卡在94%

上面说是因为sass-loader的版本过高导致,因其最新版本为8.0.0,此会导致编译出错
解决办法
1.将package.json中的sass-loader的配置修改成低于8.0.0版本,我按照上述链接中的版本,修改成7.3.1

"sass-loader": "^7.3.1",

2.将安装的node_modules项目依赖找到sass-loader删除,重新安装,
sass-loader版本会自动变成7.3.1版本。

npm install sass-loader node-sass -D  (-D是 --save-dev 的简写)

3.重新运行项目 npm run dev

4.问题解决,并不会报错

作者:diuren1205