记一次macOS Mojave升级GCC

服务器

浏览数:137

2019-11-2

AD:资源代下载服务

目录

  • 前言
  • 安装GCC
  • 最后

前言

最近迷上了泛型编程, 看到了C++11, 14, 17的很多酷炫新特性. 之前也是在Linux下也跑了一些代码, 所以不觉得放到mac会有什么问题, 直到我看了mac默认的GCC版本, 4.2.1. C++11需要至少GCC4.7. 那这样肯定是不行的.

安装GCC

于是我呼唤homebrew

brew search gcc

image

作为一个编程多年, 趟过无数坑的渣渣, 我一般不会直接选最新, 于是先尝试brew install gcc@4.9. 很遗憾, 不行. 然后我brew install gcc@5. 下载成功, 然后我打开我的.zshrc, 最后写入:

alias gcc='gcc-5'
alias cc='gcc-5'
alias g++='g++-5'
alias c++='c++-5'

source更新下.zshrc. 找了一个cpp文件开始编译.

image

果不其然, 报错了. stackoverflow一下, 说是安装xcode-select, 很遗憾, 我已经装了. 然后说是, open /Library/Developer/CommandLineTools/Packages/macOS_SDK_headers_for_macOS_10.14.pkg, 很遗憾, 我安装失败.
于是我觉得从5跳到6. 重复刚才的操作:

image


image


image

然后编译, 成功运行.

最后

喜欢记得点赞, 有意见或者建议评论区见哦~

作者:SeanDepp