在go modules里使用go get进行包管理

c/c++

浏览数:273

2019-5-22

AD:资源代下载服务

上一篇文章里我们介绍了go modules的初步使用,现在我们来更深入的了解一下如何使用go get在module中管理依赖。

module下的包管理

首先我们介绍过go mod edit修改go.mod,然而它有两点缺陷:

  • 首先是它的-require必须接受“package@version”这种形式,缺一不可,而且不能识别文档规定的master和latest标志。
  • 其次是edit只适合用于修改依赖版本,给package改名,屏蔽特定的package这三个功能,不适用于添加依赖。

好消息是go get现在有了在modules中添加/修改/更新package的能力。

想要完整体验go modules,我们需要选择一个GOPATH以外的目录,并且设置GO11MODULE=on,这样使用go get时只会影响当前的main module,不会污染GOPATH。

这次我选用自己做着玩的玩具项目演示在没有进行包管理的项目中使用go modules。(关于vendor的迁移,可以使用go mod vendor -v,详细介绍以后会有)。

我们将项目clone到非GOPATH的路径下,然后使用

go mod init [project name]

初始化module。初始化后的目录:

这时go.mod还是空的,我们知道go build会更新go.mod,所以我们先go build

默认会使用go get获得latest的package,现在go.mod已经被更新了,项目也成功被编译,这是go.mod:

module schanclient

require (
    github.com/PuerkitoBio/goquery v1.4.1
    github.com/andybalholm/cascadia v1.0.0 // indirect
    github.com/chromedp/chromedp v0.1.2
    golang.org/x/net v0.0.0-20180826012351-8a410e7b638d // indirect
)

indirect的意思是指这个package被子module/package依赖了,但是main module并没有直接import使用,也就是所谓的间接引用。

通常,go.mod使用默认行为就可以很好地完成包管理,不过生活中总是有些例外。

我们看到chromedp使用了0.1.2版本,这是三个月前的版本了,最新的commit在上个月,go mod edit需要明确指定版本号或者commit的时间+checksum,显然这很麻烦,不是我们希望的。

那么我们要如何才能使用最新的版本而不是最新的tags呢?

又或者我们不想要最新的版本,需要某个特定版本的package呢?

这就是版本选择的内容了。

go get的新特性——版本选择

以前有过gopkg.in+go get这种解决方案,而新的go get所支持的版本选择则是这一方案的进一步扩展,看几条规则:

  • go get会自动下载并安装package,然后更新到go.mod中
  • 可以使用go get package[@version]来安装指定版本的package,不指定version时默认行为和go get package@latest一样
  • version可以是vx.y.z这种形式或者直接使用commit的checksum,也可以是master或者latest
  • 当version是latest时,也就是默认行为,对于有tags的package,会选取最新的tag,对于没有tags的package,则选取最新的commit
  • 当version是master时,不管package有没有打tag,都会选择master分支的最新commit
  • 可以在version前使用>,>=,<,<=,表示选取的版本不得超过/低于version,在这个范围内的符合latest条件的版本
  • go get -u可以更新package到latest版本
  • go get -u=patch将只更新小版本,例如从v1.2.4到v1.2.5
  • 当想要修改package的版本时,只需要go get package@指定的version即可

那么我们想要把chromedp改用最新版本就很简单了:

go get github.com/chromedp/chromedp@master

现在go.mod里已经将chromedp更新了:

module schanclient

require (
	github.com/PuerkitoBio/goquery v1.4.1
	github.com/andybalholm/cascadia v1.0.0 // indirect
	github.com/chromedp/chromedp v0.1.3-0.20180717231922-bf52fed0d3e6
	golang.org/x/net v0.0.0-20180826012351-8a410e7b638d // indirect
)

如果我们现在想要添加额外的package呢?

直接使用go get就可以了,比如我现在想用gorm往数据库存数据:

go get github.com/jinzhu/gorm

更新后的go.mod

module schanclient

require (
	github.com/PuerkitoBio/goquery v1.4.1
	github.com/andybalholm/cascadia v1.0.0 // indirect
	github.com/chromedp/chromedp v0.1.3-0.20180717231922-bf52fed0d3e6
	github.com/jinzhu/gorm v1.9.1 // indirect
	github.com/jinzhu/inflection v0.0.0-20180308033659-04140366298a // indirect
	golang.org/x/net v0.0.0-20180826012351-8a410e7b638d // indirect
)

我们看到latest版本的gorm已经被添加了,当然因为我们在main module里没有import使用它,所以是indirect的。

如果我们想用v1.9的gorm:

go get github.com/jinzhu/gorm@v1.9

很遗憾,版本选择是从大版本到小版本的顺序,如果有v1.9和v1.9.1,那么当你指定v1.9时会自动选取小版本号最高的版本,除非除了v1.9之外没有其他的v1.9.z的tag存在,在这里就是v1.9.1。

还有一点值得一提,go build和go test只会将go.mod中没有的package添加进去,不会覆盖或者改变go get引入的规则,所以不用担心他们会冲突。

是不是觉得和venv+pip很像,没错,这说明go的包管理工具也逐渐步入现代化了。

至于屏蔽package,删除package以及为package改名(比如golang.org/x/…的访问不了的package),这些是go mod edit的功能,具体的请查看go help mod edit。

因为go modules的资料还不完善,所以我也是对着文档边看边做,难免会有疏漏和错误,欢迎大家指正!

作者:apocelipes